Problem with US Fanfold

How can I change the right margin of US Fanfold from 2" to say 0.5". I am using EPSON FX 1170. I could not just get it everytime I change the right margin to 0.5" it turns back again to 2". Is there any way on how to do this?

Thanks.


Post your answer or comment

comments powered by Disqus
My boss has requested a report to show our department's productivity and I am have having troubles building one! The first problem is that I am not the person who set up this database and they are no longer with us.

I am trying to build a report through the report wizard, however when I click finish it tells me, "You have chosen fields from record sources which the wizard can't connect. You may have chosen fields from a table and from a query based on a table. If so try choosing fields from only the table or only the query."

I am selecting only queries... if the query was based on a table how do I fix that so it shows up in my report?

Any assistance in this matter is appreciated!

Hi all,

I have a problem with macro.

I have one table called customer, which has the following fields,

customer name
country code
customer type


I have created a macro, using transfertext, did the following
DoCmd.TransferText acImportDelim, "customer Import Specification", "customer", "c:Cust.txt", false, ""

c:cust.txt is a tab delimited file which has the following data

AGAN US CD
AO-TECH P/L US AE

everytime I run it, first two column data is inserted, but the last column data
"CD" and "AE" never inserted into table.

any idea? could someone help me with this? thanks a lot!

I have designed a way of creating a schedule using a Microsoft Access form and Visual Basic, which works exactly how I want, except for the fact that the date doesn't know which continent it's in. I know a lot of people have had problems with date, and I have looked at lots of solutions on forums, but none of these quite help with my problem.

Essentially in my form you create a schedule, which can either be one date, or formed from multiple dates. When multiple dates are chosen you select a Start Date and End Date and then a selection of days (Mon, Tues, Wed) and weeks (All weeks, 1st week, 2nd week) where there will be scheduled dates. This works great except that for dates greater than the 12th day of the month it shows as US, while for the others it shows in English format, i.e.

2nd March = 03/02/2011 (would display as US)
20th March = 20/03/2011 (displayed in English format)

My preference would be for the dates to all show in the English format, but wouldn't mind if I could get them all to display in the US format. The problem is that it's always a mix of both. Here's my VB coding for the dates. Is there anything I could add which would ensure that the format is correct. I've tried using the Format function but it's produced exactly the same results.


	Code:
	Private Sub cmdBuildSchedule_Click()
    Dim datThis As Date
    Dim strSQL As String
    Dim db As DAO.Database
    Dim intDOW As Integer 'day of week
    Dim intDIM As Integer 'Day in month
    If Me.grpRepeats = 2 Then
        If Not CheckDates() Then
            Exit Sub
        End If
    End If
    If Not CheckTimes() Then
        Exit Sub
    End If
    
    Set db = CurrentDb
    If Me.grpRepeats = 2 Then 'need to loop through dates
        For datThis = Format(Me.txtStartDate, "dd/mm/yyyy") To Format(Me.txtEndDate, "dd/mm/yyyy")
            intDIM = GetDIM(datThis)
            intDOW = Weekday(datThis)
            If Me("chkDay" & intDIM & intDOW) = True Or _
                    Me("chkDay0" & intDOW) = True Then
                strSQL = "INSERT INTO tbl_temp_schedule_dates ( tscDate ) " & _
                    "Values(#" & _
                    datThis & ")"
                db.Execute strSQL, dbFailOnError
            End If
        Next
     Else  'dates are there, just add the title, notes, times, location, Activity
        strSQL = "Update tbl_temp_schedule_dates Set "
            
        db.Execute strSQL, dbFailOnError
    End If
    Me.sfrm_temp_schedule_edit.Requery
    MsgBox "Temporary schedule built. " & _
        "You can now edit the schedule and " & _
        "append to the permanent schedule.", vbOKOnly + vbInformation, "Temp schedule complete"
End Sub

I've stripped out the mentions of the other fields as these didn't really need to be in there.

Here's the function I use for when it's a multiple date activity:


	Code:
	Private Sub grpRepeats_AfterUpdate()
    Dim ctl As Control
    Dim intCounter As Integer
    Dim intWeek As Integer
    Dim intDay As Integer
    Me.txtEndDate.Visible = (Me.grpRepeats = 2)
    Me.txtStartDate.Visible = (Me.grpRepeats = 2)
    Me.sfrm_temp_schedule.Visible = (Me.grpRepeats = 1)
    For intWeek = 0 To 5
        For intDay = 1 To 7
            Set ctl = Me("chkDay" & intWeek & intDay)
            ctl.Visible = (Me.grpRepeats = 2)
            ctl.Value = 0
        Next
    Next
    Select Case Me.grpRepeats
        Case 2  'repeating
        Case 1
    End Select
End Sub

Sorry for such a long entry. Does anyone have any idea of how to cure this problem??

Thanks for any help!
Russ

My database I am creating is acting up again. I have a button on the switchboard which runs a macro to open up a form in read-only mode. On that form is an "edit" button, that when clicked, will run a macro to reopen the form in edit mode. This works great with the main form, but within this main form I have four subforms as well. It is the subforms that I am having problems with.

I went into the form properties for each of the subforms and set the allow edits, allow deletions, and allow additions controls all to yes. Immediately after doing this everything works great. I can open the main form in read-only mode, and the subforms are also in read-only mode. Then when I click the edit button, all of the forms switch to edit mode. However, once I close the application and come back in the next time, for some reason the allow edits, deletions, and additions choices have all defaulted back to no for each of my subforms. Does anybody have any idea what is causing this to happen? Is my first macro that opens the forms in read only mode causing the allow edits, deletions, and additions buttons to default back to no? Any help would be greatly appreciated because like us all, there is a deadline looming on the not so distant horizon.

I have 2 cascading combo boxes. Thr first calls all 5o states in the US. The Second is "Supposed" to called the call all the cites and zipcodes for the state selected. I based them on the sample cascading db from this forum modified for my db. I have a problem with my WHERE clause. Without the WHERE Clause Combo2 works fine. It shows every record in the table. When I add the WHERE Clause It won't run. I am asked for a parameters for each field in the second combobox.
Table1 has 2 fields-StAbb(PK) and State. Table2 has 5 fields-ZipID,ZipCode, City, & StAbb(FK).
I have a query for each table that the combo boxes run off.

The rowsource for combo1 is
"SELECT tbl_states.StAbb, tbl_states.State FROM tbl_states ORDER BY tbl_states.StAbb;"

The rowsource for Combo2 is:
"SELECT qry_zipcodes.ZipID, qry_zipcodes.City, qry_zipcodes.ZipCode, qry_zipcodes.StID FROM qry_zipcodes WHERE qry_zipcodes.StAbb=Forms!frm_clirntinformation!com bo24 ORDER BY [City], [ZipCode];

It doesn't matter whether I run them off the querys or directly off the underlying tables. The same thing happens. Can anyone tell me what I am doing wrong? As far as I can see I followed the example db.

Hi,
I'm fairly new to Access 2000 and have a small, cosmetic problem with previewing Reports. All I want to do is: When I preview a Report prior to printing I want the Report screen maximized. How do I set it to do so automatically?
Pozko

Hello,

I have a problem with property BackColor. I would like to put the back color (by code VBA and not by the option of formating) according to the value of a field but I do not arrive there in spite
of my many test and my research. Could you help me.

I have do this like function:

' This function doesn' t run and I don' t No why!!!!
Private Sub Report_Page()
If Me![Type ] = "5260" Then
Me![Type].BackColor = RGB(0, 25, 255)
Else Me![Type].BackColor = RGB(0, 0, 255)
End if
End Sub

I wanted to put in Excel my state in Excel and it does not keep the colors during the transfer, is this normal?.


Thank you for your assistance

Nilses

Hi All

I have a problem with some coding I have entered into a report I have created.

My report comprises of 3 fields - MyDate, MyDay and Overtime.

I want the report to show Saturdays in red, therefore I have entered the following code into the on format part of my detail part of my report: -

If Me.MyDay = 7 Then
Me.MyDay.FontBold = True
Me.MyDay.ForeColor = vbRed
Else
Me.MyDay.FontBold = False
Me.MyDay.ForeColor = vbBlack
End If

When I run the report everything is displayed in black.

What am I doing wrong?

I'd appreciate anybody's help on this.

I am trying to design a report for database in which I have used list boxes for some of the fields.

Instead of printing just the value that was selected from the list box, the report prints out the entire list of available values, and blacks out the one item that was selected.

This is not an especially helpful way to display data.

Can anyone tell me what I am doing wrong? Is more likely to be a problem with the way I set up the report, or the way I set up the list?

I seem to have a problem in creating reports. Everytime I create one, whether its with the wizard or not, I get an 'Enter Parameter Value' box with 'Trim'. This has only occurred since converting it from Access 97 to Office XP and back again. I also now seem to have another problem with queries. I have a date field in one of my tables and when I run a simple query such as Date() it says its typed incorrectly or is too complex. This also has only happended since converting.

Any ideas how to rectify this?

I have a problem with designing a report. I have three tables (1-clubs 2-players 3-player history). I need a report to display by club,then group by players assigned to the club ,the players history records.

i.e
club 1 - harchester united (clubs table)

joe bloggs(players table) 12/10/2004 19/10/2004 24/10/2004
fred smith null 19/10/2004 24/10/2004

1 -where null is shown the player did not play. This is where a record in the player history table does not exist for that date and player.
2 -There will be a maximum of 5 colums that will be displayed for played dates.
3 - Each column will have a header of PLAYED

Unfortunatley i can get the played records to display down the page but i need them to display across the page so i can use landscape format.

I need some urgent help on this as i am struggling.You can email me on mitch97144@aol.com

HELP?????

If i were to ask the user to select a date-range (start & end) when running the report would i need to do this as a query.

I'm having a problem with my lables defaulting to printing up and down. I use the wizard to create a labels sheet and everything works great prints left to right and then all of a sudden i go back in there and the labels are up and down. Cant figure out what is wrong with this i need help asap. Please anyone!!

Hi,
I am having some problems with the following script:

DoCmd.OutputTo acOutputReport, "PUR_PURCHASEORDER", _
acFormatSNP, "ttt1.snp", False

When I execute this, the SNP file gets created but my Access gives error “MS Access has encountered a problem and needs to close” and closes.

I am working on Windows XP / Access-2002 SP3. I also have Snapview Ver10.0.

Can anybody tell me what’s wrong in this?

I'm sorry if my english is not good but i'll try to do my best

I've got a problem with the printing of reports when they are opent Dialog (acDialog), when I open them normal (non pop-up) i can print them without a problem. We only have network printers over here.

When i let the dialog report print the page there happens nothing?
How can i solve it?

Regards

Spirit

You probably should cut and paste this into Word so the columns below align

I have a problem with a report. I have set up a generic process to compare any two files. After loading the files into an access database I run a series of generic queries and they identify any difference in any pair of records and displays both of the fields. Missing records are taken care separately.

To avoid running 30 different queries, I would like to put them in a report. I am using sub reports and cannot get them to work I have 2 problems:

1) When I open the detail section up enough to insert the sub report, it causes the query returns on the main report to be spread far far apart (spacing 6-10 lines apart) It’s almost as if I need additional detail lines for each sub report. How can I solve this?
2) Even though the second report will function on its own, when I insert it into the Main report, it cannot find its column (The field). I have opened up the properties of the first subreport (field 2) and set the sources equal to the MAS.FIELD2, and it still doesn’t work.
What am I doing wrong?

Database, query and report layout below (seven records on each file)


MAS file IVT file MASID and IVTID are keys

MASID Field1 Field2 Field2 IVTID Field1 Field2 Field3
1...........A1.......B1........C1..............1.. .........A1.......B1........C1............all fields match
2...........A2.......B2........C2..............2.. .........A2.......XX........A2.......... second field does not
3...........A3.......B3........C3..............3.. .........A3.......A3........A3............all fields match
4...........A4.......B4........C4..............4.. .........A4.......A4........YY............third field does not
5...........A5.......B5........C5..............5.. .........A5.......A5........A5........ ...all fields match
6...........A6.......B6........C6..............6.. .........ZZ.......A6........A6 ......... first field does not
7...........A7.......87........C7..............7.. .........QQ......A7........A7............first field does not

All of the queries are as follows: (If the indexes match, do the corresponding fields match?)

SELECT MAS.MASID, MAS.Field2, IVT.Field2 < ======= The name changes from
FROM IVT, MAS Field1 to Field2 to Field3 etc.
WHERE (((IVT.IVTID)=MAS.MASID) And ((IVT.Field2)MAS.Field2));

Query 1 (FIELD 1) MASID MAS.FIELD1 IVT.FIELD1
looks like this..........................6................... A6....................ZZ
...........................................7...... ..............A7.....................QQ


Query 2 (FIELD 2) MASID MAS.FIELD2 IVT.FIELD2
...........................................2...... ...............B2.....................XX


Query 2 (FIELD 2) MASID MAS.FIELD3 IVT.FIELD3
............................................4..... ..............C4............ .........


The report I want should somehow report on all the results.

Probably like this: (unless you can think of a better layout)


REPORT TITLE

MASID MAS FIELD IVT FIELD

FIELD 1..................6....................A6........ ...............ZZ
............................7....................A 7.......................QQ

FIELD 2.................2......................B2....... ............... XX

FIELD 3.................4......................C4....... ................YY


If I can leave off the report, a Field Line where the data is the same in both files, that would great.

I am having problems with the following code that is in the On Format event in the detail section of a report.


Private Sub Detail_Format(Cancel As Integer, FormatCount As Integer)
‘***************************
‘ Change font color when translator name is “L” for Lamdin
‘ ”PM” for Patterson-Meyer
‘ ”PR” for Patterson-Robinson
‘***************************

If Me.[txtTrans] = "L" Then
Me.[txtContext].ForeColor = 0 'black
ElseIf Me.[txtTrans] = "PM" Then
Me.[txtContext].ForeColor = 255 'red
ElseIf Me.txtTrans = "PR" Then
Me.txtContext.ForeColor = 16711680 'blue
Else: Me.[txtContext].ForeColor = 0
End If
End Sub

As you may surmise, the objective is to have the text in the [txtContext] field change font color (ForeColor) based on the value that is in [txtTrans].

The code works partially. When [txtTrans] = “PR” or “PM” the [txtContext] field appears correctly on the report, however the contents of [txtContext] does not appear AT ALL on the report. Moreover, when I filter the underlying query for the report to include ONLY “L” in [txtTrans] a VB error is generated.

What am I doing wrong?


Thanks,

Rick

I have a problem with a report based on a crosstab query

The crosstab query shows the number of players per team by date as the sample below shows.

Date Total of Last 1 2 3 4 5 …..
2006/05/11 173 11 8 8 9 11
2006/05/18 149 8 7 10 8 11
2006/05/25 181 13 7 11 10 11
2006/06/01 160 11 8 9 10 8
2006/06/08 162 7 11 8 11 10


I was asked if I could provide totals for each team over all the dates. I couldn't see a way to add totals within the crosstab query so I created a report based on the crosstab query.

The report works with out a problem until I try to group by year. When grouping by year the order of the dates comes out incorrectly, if I group by month or day the sort order works fine. I typed the following sample to show what I am seeing. I have also attached a screen print of the report output.

Date Team 1 Team 2 Team 3 ......

2006/07/13 10 6 10
2006/05/18 8
2006/05/25 13
2006/06/01
2006/06/08
2006/06/22
2006/05/01
.....

The totals in the group footer are correctbut as yiou see above the dates are not in the correct order.

If anybody has an idea why the sort order gets messed up I would appreciate the help.

Thanks Kevin ….

One user is having the problem with Prewing and printing all reports no matter what Access database she uses. The report looks very small and shrunk located in upper left corner. And that is the way how it prints sometimes. The other times even though it looks it is shrunk on the screen, it prints fine in its correct size.
The weirdest thing is that this is not happening on the consistent basis. It is happening very randomly.

No other user has these problems with same reports.

Any help would be appreciated

Does anyone know of any problems with Access2003 creating reports in a split database?!
To help with the load time of a medium sized database, I recently split it in two.
When a user now runs one of the reports, an error message appears stating "Cannot open anymore databases". (There are no other databases open!) The report in question has a subreport included in it.
When the same report is run in the non-split version, the error does not appear.
It appears that having a subreport within a report in a split database doesn't work!
Any ideas?

Thanks.

Hi,

i wonder if someone could help me with a problem i have? here is the background. I have created an access database for the business of a relative who isnt too computer literate, what i have produced is effectivly a simpler version of mail merge. I have a form where he enters some information that passes data to a report which is letter. The customers address along with some other information layed out as a standard letter which he can then print onto A4 headed paper. This side of things works as i want it to but i have a problem with the layout of the letter.

The problem is the first page which is the letter for the first customer prints fine but every letter after this in the run comes out slightly too high up the page and doesnt look right with the headed notepaper its printed on. I have temporarily fixed this by lowering all the items in the report so the first one is too low but the other 1000 or so letters would be right. I was just wondering if anyone has a suggestion as to how i can make all the letters be the same position on the sheet of A4 they are printed on.

Thanks in advance for a any advice, i will provide more details if any are needed.

Morning all,

I'm having real fun with Access '07.... not.

I've designed a report that effectively prints a list of bookings based on a user-input date range, grouped by the staff member that's booked to lead. All well and good (did have a minor problem with a multiple value list but sorted that), except that when printed/viewed etc, instead of printing the [Staff Member] field it puts their [ID] field in instead... any ideas what I can do to correct this?

I did try removing the field from the report as it was a text box and re-inserted as a Combo box, but it stopped working altogether and duplicated all the bookings for each staff member, still only printing the ID instead of a name!!!

Thanks in advance, it's giving me a headache!

Barry

Hello Friends

I have a problem with printing reports based on date query (the date is placed in a subform on the Mainform).
What I need is to print these reports directly by one command button without showing the reports, under some conditions.
May be I couldn't explain my case but I will tell in few details :

I have 8 reports :
Report 1 , Report 2 , Report 3 , Report 4 , Report 5 , Report 6 , Report 7 , Report 8
All these reports based on date query, when the user hit the command button it should give prompt box for date to specify the desired date.

First Step
Report 5 , Report 6
will be printed according to the user decision, it should be a message appears to the user asking him if he need to print those reports or not.
If Yes, a prompt box for date will appear to enter the desired date and the reports will be printed and move to the second step
If No, the reports won't be printed and move to the second step.

Second Step
Report 7 , Report 8
will be printed according to the user decision, it should be a message appears to the user asking him if he need to print those reports or not.
If Yes, a prompt box for date will appear to enter the desired date and the reports will be printed and move to the third step
If No, the reports won't be printed and move to the third step.

Third Step
Report 1 , Report 2 , Report 3 , Report 4
A prompt box for date will appear to enter the desired date and the reports will be printed and finish.

How I can do this by VB code
I hope that I succeeded in explaining my case to get your help

Thank you in advance

Waiting your needed help




I have a problem with printing reports based on date query (the date is placed in a subform on the Mainform).
What I need is to print these reports directly by one command button without showing the reports, under some conditions regarding multiple copies

May be I couldn't explain my case but I will tell in few details :

I have 8 reports :
Report 1 , Report 2 , Report 3 , Report 4 , Report 5 , Report 6 , Report 7 , Report 8
All these reports based on date query, when the user hit the command button it should give prompt box for date to specify the desired date.

First Step
Report 5 , Report 6
will be printed according to the user decision, it should be a message appears to the user asking him if he need to print those reports or not.
If Yes, a prompt box for date will appear to enter the desired date and the reports will be printed and move to the second step
If No, the reports won't be printed and move to the second step.

Second Step
Report 7 , Report 8
will be printed according to the user decision, it should be a message appears to the user asking him if he need to print those reports or not.
If Yes, a prompt box for date will appear to enter the desired date and the reports will be printed and move to the third step
If No, the reports won't be printed and move to the third step.

Third Step
Report 1 , Report 2 , Report 3 , Report 4
A prompt box for date will appear to enter the desired date and the reports will be printed and finish.

The problem that when I hit the command button it prints just one copy for the first step and then print the form itself until the last record

This is the code I'm using

On Error GoTo Err_Command12_Click
a = MsgBox("Do you want to print Report1 & Report 2?", vbYesNo, "Notification")
If a = vbYes Then
DoCmd.OpenReport "Report1", acViewNormal
DoCmd.PrintOut , , , , 2
DoCmd.OpenReport "Report2", acViewNormal
DoCmd.PrintOut , , , , 1
Else
MsgBox "Ok , the reports will not be printed ! Well Done", vbInformation, "No Print"
End If

e = MsgBox("Do you want to print Report3 & Report 4?", vbYesNo, "Notification")
If e = vbYes Then
DoCmd.OpenReport "Report3", acViewNormal
DoCmd.PrintOut , , , , 2
DoCmd.OpenReport "Report4", acViewNormal
DoCmd.PrintOut , , , , 1
Else
MsgBox "Ok , the reports will not be printed", vbInformation, "No Print"
MsgBox "Wait until the printer finish then organize your reports", vbInformation, "Done"
End If

DoCmd.OpenReport "Report5", acViewNormal
DoCmd.PrintOut , , , , 2
DoCmd.OpenReport "Report6", acViewNormal
DoCmd.PrintOut , , , , 2
DoCmd.OpenReport "Report7", acViewNormal
DoCmd.PrintOut , , , , 1
DoCmd.OpenReport "Report8", acViewNormal
DoCmd.PrintOut , , , , 1

Exit_Command12_Click:
Exit Sub

Err_Command12_Click:
MsgBox Err.Description
Resume Exit_Command12_Click

I'm waiting your help

Thank you in advance

I am having a problem with setting the alternative row color. Some reports work and some do not. I have both types defining the detail section.

Is there some setting I need to check? Everything looks good and consistent as far as I can tell. It appears to ignore the background setting on the ones that fail.

Any ideas?

Thanks


Not finding an answer? Try a Google search.